Applications - Java Support (Elasticsearch (We think that we will release…
Applications - Java Support
Oracle JDK / JRE 1.8
Only supported platforms for Jira 7.1 are available
We very much want the Elastic Stack to be compatible with the new non-LTS releases as fast as possible because those releases will contain new features that can make Elasticsearch and the rest of the Elastic Stack faster. [
We think that we will release a version of the Elastic Stack that is compatible with both the newest LTS release and the newest release. [
Once Java 10 is released we'd like to release a version of Elasticsearch that is compatible with Java 8 and Java 10. Then a version that supports just Java 11 because it'll be both the newest LTS release and the newest release.
This compatibility plan is a long way from becoming a support policy. We can't guarantee that we're going to do what we planned.
is built using Java, and requires at least Java 8 in order to run. Only Oracle’s Java and the OpenJDK are supported. The same JVM version should be used on all Elasticsearch nodes and clients.
We recommend installing Java version 1.8.0_131 or a later version in the Java 8 release series. We recommend using a supported LTS version of Java. Elasticsearch will refuse to start if a known-bad version of Java is used.
Elasticsearch 6.X doesn't support Azul Zing
Oracle and OpenJDK builds supported
runs in Java, release 1.6 or greater (JDK 6 or greater).
is to have a working
From a security perspective, we recommend you use the latest released version of JDK 1.8 as older freely available versions have disclosed security vulnerabilities. LinkedIn is currently running JDK 1.8 u5 (looking to upgrade to a newer version) with the G1 collector. [
The latest version of Java 8, either the Oracle Java Standard Edition 8 or OpenJDK 8. To verify that you have the correct version of java installed, type java -version.
One more Link
Support OpenJDK 8
Starting with DSE 5.1.11 and 6.0.3, DataStax does more extensive testing on OpenJDK 8. This change is due to the end of public updates for Oracle JRE/JDK 8.
Support Oracle JDK/JRE 8
The latest build of the supported Oracle JRE or JDK 8 version is recommended.
DSE 6.7, 6.0
OpenJDK 8 (at least 1.8.0_151)
Oracle Java 8 (at least 1.8.0_151)
DSE 5.1, 5.0
OpenJDK 8 (at least 1.8.0_40)
Oracle Java 8 (at least 1.8.0_40)
Spark runs on Java 8+
Note that support for Java 7 were removed as of Spark 2.2.0